2020年12月14日,阿里云应急响应中心监测到 XStream 官方发布安全公告,披露 CVE-2020-26258 XStream 反序列化致SSRF漏洞、CVE-2020-26259 XStream 反序列化致任意文件删除漏洞


漏洞描述

XStream是一个常用的Java对象和XML相互转换的工具。近日XStream官方发布安全更新,修复了XStream 反序列化漏洞(CVE-2020-26258、CVE-2020-26259)。攻击者通过构造恶意的XML文档,可绕过XStream的黑名单,触发反序列化,从而造成CVE-2020-26258 SSRF漏洞,以及 CVE-2020-26259 任意文件删除漏洞。阿里云应急响应中心提醒 XStream 用户尽快采取安全措施阻止漏洞攻击。


影响版本

XStream < 1.4.15


安全版本

XStream 1.4.15


安全建议

针对使用到XStream组件的web服务升级至最新版本:http://x-stream.github.io/changes.html


相关链接

https://github.com/x-stream/xstream


阿里云云安全中心应急漏洞模块已支持对该漏洞一键检测
阿里云云防火墙已可防御此漏洞攻击
阿里云WAF已可防御此漏洞攻击

我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云应急响应中心

2020.12.14

欢迎关注阿里云应急响应公众号

点击收藏 | 0 关注 | 0
  • 动动手指,沙发就是你的了!
登录 后跟帖