2020年11月26日,阿里云应急响应中心监测到 Drupal 官方发布安全更新,修复了 Drupal 远程代码执行漏洞(CVE-2020-28949、CVE-2020-28948)。


漏洞描述

Drupal是使用PHP语言编写的开源内容管理框架。11月25日Drupal官方发布安全更新,修复了Drupal 远程代码执行漏洞(CVE-2020-28949、CVE-2020-28948)。Drupal使用了PEAR Archive_Tar作为依赖库,在处理如.tar、.tar.gz、.bz2或.tlz等格式的压缩包时,由于过滤不严,可能导致存在PHAR反序列化漏洞,从而造成远程代码执行。阿里云应急响应中心提醒 Drupal 用户尽快采取安全措施阻止漏洞攻击。


影响版本

Drupal < 9.0.9

Drupal < 8.9.10

Drupal < 8.8.12

Drupal < 7.75


安全版本

Drupal 9.0.9

Drupal 8.9.10

Drupal 8.8.12

Drupal 7.75


安全建议

1. 升级Drupal至最新版本。

2. 设置Drupal禁止用户上传如.tar、.tar.gz、.bz2、.tlz等格式的压缩包。


相关链接

https://www.drupal.org/sa-core-2020-013


阿里云云防火墙已可防御此漏洞攻击
阿里云WAF已可防御此漏洞攻击

我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2020.11.26

欢迎关注阿里云应急响应公众号

点击收藏 | 0 关注 | 0
  • 动动手指,沙发就是你的了!
登录 后跟帖