2021年1月20日,阿里云应急响应中心监测到 Drupal 官方发布安全更新,修复了 Drupal 目录遍历漏洞(CVE-2020-36193)。


漏洞描述

Drupal是使用PHP语言编写的开源内容管理框架。1月20日Drupal官方发布安全更新,修复了Drupal 远程代码执行漏洞(CVE-2020-36193),官方评级严重。Drupal使用了PEAR Archive_Tar作为依赖库,在处理如.tar、.tar.gz、.bz2或.tlz等格式的压缩包时,由于过滤不严,攻击者可构造包含符号链接的压缩包,结合上传功能,可能导致存在目录遍历漏洞,甚至远程代码执行漏洞。阿里云应急响应中心提醒 Drupal 用户尽快采取安全措施阻止漏洞攻击。


影响版本

Drupal < 9.1.3

Drupal < 9.0.11

Drupal < 8.9.13

Drupal < 7.78


安全版本

Drupal 9.1.3

Drupal 9.0.11

Drupal 8.9.13

Drupal 7.78


安全建议

1. 升级Drupal至最新版本。

2. 设置Drupal禁止用户上传如.tar、.tar.gz、.bz2、.tlz等格式的压缩包。


相关链接

https://www.drupal.org/sa-core-2021-001



云盾WAF已可防护该类漏洞,并提供7天免费漏洞应急服务,为您争取漏洞修复时间,应急开通地址:https://c.tb.cn/I3.XzCtR

阿里云云防火墙已可防御此漏洞攻击


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。

阿里云应急响应中心

2021.1.21

欢迎关注阿里云应急响应公众号

点击收藏 | 0 关注 | 0
  • 动动手指,沙发就是你的了!
登录 后跟帖