2021年3月2日,阿里云应急响应中心监测到Apache Tomcat官方发布安全公告,披露了CVE-2021-25329 Apache Tomcat Session 反序列化代码执行漏洞。


漏洞描述

Apache Tomcat是由Apache软件基金会属下Jakarta项目开发的Servlet容器。在CVE-2021-25329 Apache Tomcat Session 反序列化代码执行漏洞中,由于官方在CVE-2020-9484漏洞修复上存在不足,攻击者可能可以构造恶意请求,绕过CVE-2020-9484补丁,造成反序列化代码执行漏洞。成功利用该漏洞需要同时满足下列四个条件:

1. 攻击者能够控制服务器上文件的内容和名称

2. 服务器PersistenceManager配置中使用了FileStore

3. 服务器PersistenceManager配置中设置了sessionAttributeValueClassNameFilter为NULL,或者使用了其他较为宽松的过滤器,允许攻击者提供反序列化数据对象

4. 攻击者知道使用的FileStore存储位置到可控文件的相对文件路径。

整体利用条件较为苛刻,实际危害相对较低,为彻底防止漏洞潜在风险,阿里云应急响应中心仍建议 Apache Tomcat用户修复漏洞。


漏洞评级

CVE-2021-25329 中危


影响版本

Apache Tomcat 10.x < 10.0.2

Apache Tomcat 9.x < 9.0.43

Apache Tomcat 8.x < 8.5.63

Apache Tomcat 7.x < 7.0.108


安全版本

Apache Tomcat 10.x >= 10.0.2

Apache Tomcat 9.x >= 9.0.43

Apache Tomcat 8.x >= 8.5.63

Apache Tomcat 7.x >= 7.0.108


安全建议

1、升级Apache Tomcat至安全版本

2、禁止使用Session持久化功能FileStore


相关链接

1、https://tomcat.apache.org/security.html

2、https://www.mail-archive.com/announce@apache.org/msg06386.html


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2021.03.02

欢迎关注阿里云应急响应公众号

点击收藏 | 0 关注 | 0
  • 动动手指,沙发就是你的了!
登录 后跟帖