2019年7月26日,阿里云应急响应中心监测到有安全研究人员披露XStream < 1.4.11 存在远程代码执行高危漏洞,利用可导致远程执行服务器命令,请使用到XStream组件的用户尽快升级至安全版本。


漏洞描述

XStream官方本在v1.4.7版本修复了CVE-2013-7285漏洞,但是在修复CVE-2017-7957漏洞时不当处理导致CVE-2013-7285漏洞回滚重现,最新版本的1.4.11.1已针对此问题作出修复。1.4.11存在功能BUG,无法在java8以下版本运行,故阿里云应急响应中心建议用户升级XStream至1.4.11.1。


影响版本

XStream < 1.4.11


安全版本

XStream 1.4.11.1


安全建议

针对使用到XStream组件的web服务升级至最新版本:http://x-stream.github.io/changes.html


相关链接

https://github.com/fxdkyou/xstream_v1_4_9_security_issues

阿里云WAF已可防御此漏洞攻击


我们会关注后续进展,请随时关注官方公告。

如有任何问题,可随时通过工单或服务电话95187联系反馈。


阿里云应急响应中心

2019.7.26

欢迎关注阿里云应急响应公众号

点击收藏 | 0 关注 | 0
  • 动动手指,沙发就是你的了!
登录 后跟帖